[Mono-devel-list] Threading Problem (Bug?):

Dick Porter dick at ximian.com
Fri Mar 21 06:37:58 EST 2003

On Fri, 2003-03-21 at 11:15, Charles-Louis wrote:
> Hi,
> I'm having a Thread related problem in my program.I get different Errors
> when I run it with mono on Linux (RedHat 8.0) and Windows,and wanted to
> know if anyone knows of some issues.
> I have to say that, when I ./configure mono, I have to set the
> SIZEOF_SUNPATH to 108, because it defaults to 0.

If you could figure out why configure gets this wrong for you, it would
be appreciated.

> Basically, my application starts a Thread when I cklick on a Button in a
> GTK# window. (after running the program with /WINDOW option)
> So, when I start the Thread for the first time, I get a
> NullReferenceException (actually, I get two, because I start two
> threads) when I call 'Thread.Start()', and the first instruction of my
> Thread function (WorkerThread) is never executed
> (Console.WriteLine("**WorkerThread**");)... the Thread is not started.
> When I stop the Thread and restart it, everything runs ok: Thread runs
> correctly and performs the correct actions.
> Same thing when I run the Thread from the Console...
> NullReferenceException for the first time, and then everything runs OK.

No idea what's wrong, and theres no chance of me being able to debug it
without a test case.

Please add a bugzilla entry, include the version of mono you are using
and the smallest possible test sample that shows the problem.

> On mono Windows (Console), I can start the Thread normally. But when I
> stop the Thread, I get this message (on a MessageBox):
> ** ERROR **: file threads.c: line 817
> (ves_icall_System_Threading_Thread_Abort): should not be reached
> aborting...
> followed by an 'abnormal program termination'

Thread.Abort() isn't implemented on windows.

- Dick

More information about the Mono-devel-list mailing list