[Mono-devel-list] xsp-0.4 + mono-0.25 on win32?

Gonzalo Paniagua Javier gonzalo at ximian.com
Tue Jul 1 10:13:33 EDT 2003

El mar, 01-07-2003 a las 02:40, Pelle Johnsen escribió:
> Hi again,
> mono.bat which I use to run xsp, adds the path containing mcs.exe (and
> mono.exe) to the start of the windows path.
> mcs.bat is in my system root (c:\winnt)
> This is only part of the problem though - even from the commandline I can't
> invoke mcs with filenames in single quotes (') as
> Mono.CSharp.CSharpCodeCompiler does:
>   C:\work\test\csharp>mcs 'tempfname.cs'
>   error CS2001: Source file ''tempfname.cs'' could not be opened
>   Compilation failed: 1 error(s), 0 warnings
>   C:\work\test\csharp>mcs tempfname.cs
>   Compilation succeeded
> Even tried in cygwin - same result.
> >From Mono.CSharp.CSharpCodeCompiler.BuildArgs (CVS):
>   foreach (string source in fileNames)
>     args.AppendFormat("'{0}' ",source);
>   return args.ToString();
> What am I doing wrong? Surely someone must have tested xsp on win32 with
> 0.25 before me?

Yes, but recently i've only tested it under MS runtime.

It would be nice if you can help us fixing this. Does removing those
quotes and using double quotes instead in CSharpCodeCompiler.BuildArgs
fix the problem?


More information about the Mono-devel-list mailing list