[Mono-devel-list] Fresh install on Debian

Ralf M. ralfml at alfray.com
Tue Dec 2 02:32:51 EST 2003

I was able to successfully compile the mono runtime from a daily 
snapshot (mono- when the main download 
(mono-0.28.tar.gz) failed (mostly due to the CSIZE macro that has been 
cleaned in between, it was conflicting with the one in termios.h and the 
errors did not look like the ones you're showing)

The OS is a debian/ppc woody (Linux macross 2.4.20 #22 Mon Apr 28 
19:16:41 PDT 2003 ppc  740/750 GNU/Linux).


Les Ferguson wrote:

> Hi all,   I got all the source files for 0.28 & tried to install Mono (Debian 
> support seems to have been dropped after 0.26).  Now I have tried to follow 
> all the instructions but I can only get Mono to build & install properly, the 
> mcs stuff falls over ...
> make[2]: Leaving directory `/usr/local/share/mono_src/mcs-0.28/tools/mono-xsd'
> make[2]: Entering directory `/usr/local/share/mono_src/mcs-0.28/tools/
> security'
> MONO_PATH="../../class/lib:$MONO_PATH" mono  ../../mcs/mcs.exe /r:../../class/
> lib/Mono.Security.dll  -d:NET_1_1 -g cert2spc.cs AssemblyInfo.cs
> mono: relocation error: /usr/local/lib/libmono.so.0: undefined symbol: 
> g_thread_init
> make[2]: *** [cert2spc.exe] Error 127
> make[2]: Leaving directory `/usr/local/share/mono_src/mcs-0.28/tools/security'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/usr/local/share/mono_src/mcs-0.28/tools'
> make: *** [all-recursive] Error 1
> I cannot determine exactly what the process is for a fresh install from 
> tarballs, the instructs I have found make circular references to CVS 
> procedures, but I didn't want to use CVS.  Are the tarballs usable for a 
> fresh new installation ?

More information about the Mono-devel-list mailing list