[Mono-devel-list] cygwin build broken?

Atsushi Eno ginga at kit.hi-ho.ne.jp
Sat Aug 23 01:36:11 EDT 2003


Today I tried to build mono on cygwin on win2k from cvs,but I failed it.
I tried it in a newly checked out directory, and tried ./autogen.sh;make.
I built mono-0.26 release successfully on the same environment.

gcc -mno-cygwin -DHAVE_CONFIG_H -I. -I. -I../.. -I../.. -I../../mono
-D_REENTRANT -I/opt/monognome/include/glib-2.0
-I/opt/monognome/lib/glib-2.0/include -I/opt/monognome/include/glib-2.0
-DMONO_CFG_DIR=\"d:/cygwin/usr/local/etc\" -I /opt/monognome/include
-DWIN32_THREADS -O -g -Wall -Wunused -Wmissing-prototypes
-Wmissing-declarations -Wstrict-prototypes -Wmissing-prototypes
-Wpointer-arith -Wno-cast-qual -Wcast-align -Wwrite-strings -MT
assembly.lo -MD
-MP -MF .deps/assembly.Tpo -c assembly.c -DPIC -o .libs/assembly.o
assembly.c: In function `mono_assembly_setrootdir':
assembly.c:129: `path_inited' undeclared (first use in this function)
assembly.c:129: (Each undeclared identifier is reported only once
assembly.c:129: for each function it appears in.)
make[4]: *** [assembly.lo] Error 1
make[4]: Leaving directory `/home/_/cvs/mono/mono/metadata'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/home/_/cvs/mono/mono/metadata'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/_/cvs/mono/mono'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/_/cvs/mono'
make: *** [all] Error 2

Atsushi Eno

More information about the Mono-devel-list mailing list