[Mono-devel-list] freeze on FreeBSD

Martin Dvorak md at 9ll.cz
Mon Apr 28 12:07:59 EDT 2003


I've built mono from CVS on FreeBSD, fed it with mcs and class library 
compiled on Windows, set up MONO_PATH to point to lib directory and used 
ldconfig to merge libs in lib directory. Although everything seems to 
work fine, mcs always freezes when compiling e.g. mcs or gtk-sharp with 
no output.

I tried to use mint and oldmono instead of mono (mini), with different 
success: mini always freezes while eating all CPU, oldmono either 
freezes like mint or dies with System.NullReferenceException and mono 
runs for a few seconds and falls asleep. I've tried to increase mcs 
verbosity and found out that it behaves differently each run. Sometimes 
it freezes with no output and sometimes after a variable number of lines 
of output.

Does anybody run current CVS successfully on FreeBSD 5-RELEASE? Am I 
missing something or the CVS version just isn't working on FreeBSD right 
now? Are there any tests I could use to verify the mono installation?

Thank you all.


More information about the Mono-devel-list mailing list