[Mono-devel-list] Some XSP Questions

Stefan Kyntchev stefan at airweb.cc
Tue Apr 8 09:17:51 EDT 2003

I am trying to get the XSP code behind test to work. When I run it it
fails saying it can't find the code behind .
Other - non code behind tests seem to work OK. (I am using mono 0.23 and
xsp 0.3 on WindowsXP box)
The error message is:
Parser Error

Description: Error parsing a resource required to service this request.
Review your source file and modify it to fix this error. 

Error message: Directory '/D:/cygwin/usr/stefan/WebTest/server/test/bin'
not found. 
Source Error: 
Line 1: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN" >
Line 2: <HTML>

Source File: D:\cygwin\usr\stefan\WebTest\server\test\codebehind1.aspx 
It seems like it is confused by the / before D:/...
How do you fix this?
How does xsp find the path to the machine.config. When I start it it is
looking for a path C:\cygwin\home\lalo\go-mono\install\etc\mono that
does not exist on my machine. I had to create it so
server.exe can work. 
When I run just "server.exe" everything works fine, but in this case it
looks like server.exe is using Microsoft ASPX parser and compiler. I got
confident that everything works fine until I tried to
access a page that did not exist and got a Microsoft Error page
refferencing Microsoft .net framework 1.0. 
I also  noticed that mono error pages look similar, but don't have the
version at the bottom - It would be nice if they had. (I would be glad
to add this once I get everything to work)
For some reason server.exe is looking for mcs.bat in the servers virtual
root directory. I have mcs.bat in my windows directory but it refused to
use it. This is not a big deal but I am just curious. 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-devel-list/attachments/20030408/2cc3fb16/attachment.html 

More information about the Mono-devel-list mailing list