[Mono-bugs] [Bug 683043] New: Changing .axml filename from 11 to 10 characters prevents app loading into emulator

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Mon Mar 28 08:19:18 EDT 2011



           Summary: Changing .axml filename from 11 to 10 characters
                    prevents app loading into emulator
    Classification: Mono
           Product: MonoDroid
           Version: unspecified
          Platform: x86
        OS/Version: Windows 7
            Status: NEW
          Severity: Minor
          Priority: P5 - None
         Component: Tools
        AssignedTo: mono-bugs at lists.ximian.com
        ReportedBy: chris at acs-solutions.co.uk
         QAContact: mono-bugs at lists.ximian.com
          Found By: ---
           Blocker: No

Created an attachment (id=421658)
 --> (http://bugzilla.novell.com/attachment.cgi?id=421658)
VS2010 solution demonstrating the bug

Description of Problem:
When developing with VS2010 and the Android Emulator (v1.6) I added a new
layout resource with the filename "AddReading.xaml". When I pressed Ctrl-F5 to
load and run the app, I got an "Error Starting Application" dialog, and the
application had not been loaded into the emulator.

Changing the filename to any other 10-character name gave the same result, but
if I changed it to 9 or 11 characters (e.g. "AddReadin.xaml",
"AddAReading.xaml") then everything worked OK.

The attached zip file contains the project (in the non-working state). To make
it work rename "AddReading.xaml" to "AddAReading.xaml", and change line 59 in
AddReadingActivity.cs to use "Resource.Layout,AddAReading" instead of

Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.

More information about the mono-bugs mailing list