[Mono-bugs] [Bug 681841] Build on PPC fails with "Unknown error 8192"

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Thu Mar 24 04:47:40 EDT 2011



Kenneth Skovhede <kenneth at hexad.dk> changed:

           What    |Removed                     |Added
         OS/Version|Red Hat 7.0                 |Red Hat 9.0

--- Comment #2 from Kenneth Skovhede <kenneth at hexad.dk> 2011-03-24 08:47:40 UTC ---
Perhaps it is a kernel/gcc issue.
The reported crashes are from the following kernel:

With gcc version:
gcc (GCC) 4.3.0 20080428 (Red Hat 4.3.0-8)

I have also tried with the ppu-gcc compiler instead:
ppu-gcc (GCC) 4.1.1

I have also tried on the PS3 with:
gcc (GCC) 4.1.1 20070105 (Red Hat 4.1.1-52.ydl.1)

And this yields similar results.

I found this issue:

which claims that it was fixed by upgrading the kernel.

Inspired by the issue, I tried to change the 19 digit constant from:
(1125899906842624 * 8192)

which then allows the compile process to proceed a little further, but then
something else crashes.

Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.

More information about the mono-bugs mailing list