[Mono-bugs] [Bug 703824] New: Monodroid "Hello-World" for Visual Studio 2010 fails

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Tue Jul 5 02:35:43 EDT 2011



           Summary: Monodroid "Hello-World" for Visual Studio 2010 fails
    Classification: Mono
           Product: MonoDroid
           Version: unspecified
          Platform: 64bit
        OS/Version: Windows 7
            Status: NEW
          Severity: Critical
          Priority: P5 - None
         Component: Tools
        AssignedTo: mono-bugs at lists.ximian.com
        ReportedBy: dror at isecas.com
         QAContact: mono-bugs at lists.ximian.com
          Found By: Development
           Blocker: Yes

Dror Halahmi <dror at isecas.com> changed:

           What    |Removed                     |Added
               Flag|                            |SHIP_STOPPER?, CCB_Review?

Description of Problem:
I tried to create the "Hello-World" in mono for android using visual studio
2010. I followed the instructions given here:
http://mono-android.net/Tutorials/Hello_World It worked fine until this stage:
"Visual Studio will now package up your application, copy it to the emulator,
and launch it. You should see something like this once it's done:"
This stage failed. Thus, there were no signs for packaging, copying to the
emulator, launching. What I could see is that the android emulator starts with
no sign to my application. I tried to look for the app in the android apps, it
wasn't there.

I thought that I found a workaround, as follows: When I exited the emulator, I
reached back to Visual Studio, with the "Select Device" window. This time, the
window appeared with a device name "emulator-5554" highlighted in green, but
only for about 1 second (this device name or any other besides "Monodroid"
didn't appear when I tried to run the application at the beginning by clicking
CTRL-F5). If within this 1 second I clicked OK, I saw these massages one after
the other:
"Packaging application.."
"Waiting for device.."

This last message never ended, until I closed the window. This resulted in
another popup window which said:
"There were deployment errors. Continue?"
When I clicked Yes, I reached this "MonoDroid does not support running the
previous version. Please ensure your solution builds before running or
debugging it." When clicked No I reached the above mentioned deployment error
When I waited for the emulator-5554 device to disappear after 1 second, all I
could do is quiting the "Select Device" window which ended with the same
deplyoment error message.
What can I do to make it work? Someone can help, please? Thanks!

Steps to reproduce the problem:
1. Just follow the instructions here:

Actual Results:
Failure in packaging, copying to the emulator, launching

Expected Results:
Packaging, copying to the emulator, launching

How often does this happen? 
100% of the cases

Additional Information:

Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.

More information about the mono-bugs mailing list