[Mono-bugs] [Bug 667397] New: Error compiling template code

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Wed Jan 26 13:55:02 EST 2011



           Summary: Error compiling template code
    Classification: Mono
           Product: MonoDroid
           Version: SVN
          Platform: Macintosh
        OS/Version: Mac OS X 10.6
            Status: NEW
          Severity: Normal
          Priority: P5 - None
         Component: Tools
        AssignedTo: mkestner at novell.com
        ReportedBy: rickgross at mac.com
         QAContact: mono-bugs at lists.ximian.com
          Found By: ---
           Blocker: ---

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US;
rv: Gecko/20101203 Firefox/3.6.13

I created a new project in the default location ~user/Projects. Immediately 
did a compile on the template code and got the icon error. Check the 
MonoDroid application settings which had no icon reference. Changed to the 
default reference: @drawable/Icon, got same error. Realized that the 
'drawable' folder did not exist, renamed 'drawable-something' to 'drawable', 
compiled and got same error. Finally went into the 'AndroidManifest.xml' file 
and removed the icon reference. That worked and compile completed without 

Reproducible: Always

Steps to Reproduce:
Actual Results:  
Error: Tool exited with code: 1. Output: Running command:
/Developer/android-sdk-mac_86/platform-tools/aapt "package" "-f" "-M"
"AndroidManifest.xml" "-J" "src" "-F" "bin/packaged_resources" "-S"
"/Users/rickgross/Projects/HelloWorld/HelloWorld/obj/Debug/res/" "-I"
monodroid: error 1 : System.InvalidOperationException: Command failed. Command:
/Developer/android-sdk-mac_86/platform-tools/aapt "package" "-f" "-M"
"AndroidManifest.xml" "-J" "src" "-F" "bin/packaged_resources" "-S"
"/Users/rickgross/Projects/HelloWorld/HelloWorld/obj/Debug/res/" "-I"
    AndroidManifest.xml:3: error: Error: No resource found that matches the
given name (at 'icon' with value '@drawable/Icon').

 at MonoDroid.Utils.ProcessRocks+<ReadStandardOutput>c__Iterator4.MoveNext ()
[0x00000] in <filename unknown>:0 
 at Monodroid.Toolbox.InvokeCommand (IEnumerable`1 commandLine) [0x00000] in
<filename unknown>:0 
 at Monodroid.Toolbox.InvokeAapt () [0x00000] in <filename unknown>:0 
 at Monodroid.Droidinator.CreatePackagedResources
(System.Collections.Generic.List`1 javaTypes) [0x00000] in <filename unknown>:0 
 at Monodroid.Droidinator.CreateApk () [0x00000] in <filename unknown>:0 
 at Monodroid.MainClass.Main (System.String[] argv) [0x00000] in <filename

Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the mono-bugs mailing list