[Mono-bugs] [Bug 691057] New: Wrong result of SIMD operations on Intel Core/Core 2 while 100% proper on Opteron

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Sat Apr 30 08:21:59 EDT 2011



           Summary: Wrong result of SIMD operations on Intel Core/Core 2
                    while 100% proper on Opteron
    Classification: Mono
           Product: Mono: Runtime
           Version: 2.10.x
          Platform: x86
        OS/Version: All
            Status: NEW
          Severity: Major
          Priority: P5 - None
         Component: JIT
        AssignedTo: lupus at novell.com
        ReportedBy: konrad.kruczynski at gmail.com
         QAContact: mono-bugs at lists.ximian.com
                CC: konrad.kruczynski at gmail.com
          Found By: Community User
           Blocker: ---

Created an attachment (id=427423)
 --> (http://bugzilla.novell.com/attachment.cgi?id=427423)
Original and simdified version of C# n-body benchmark

Description of Problem:
I wanted to contribute a simdified version of n-body benchmark to
Program was completed and tested on AMD Opteron (with Mono 2.10.1) and worked
perfectly. Results was 100% ok and was a lot faster than nonsimdified
(original) version. I contributed new version to benchmark (it still waits for
evaluation). In the meantime I also checked program on Intel Core. I was
surprised when not only it worked much slower, but also gave improper results.
On shootout one can see very similar simdified version of n-body written in C,
which gives correct results, so it is not just simd related problem. Also, as I
said, on AMD Opteron, everything is fine. Both programs are short and clear.

Steps to reproduce the problem:
1. Compile attached nbody.cs (original program) and nbody-simd.cs (referencing
2. Run both programs.

Actual Results:
Result of both programs should be identical regardless of the CPU.

Expected Results:
Proper result on AMD Opteron, improper on Intel Core/Core 2 (none others

How often does this happen? 

Additional Information:
Compiled EXE file was moved from one platform to another, so this is not
related with msc, but rather JIT. Tested on Windows and Linux (Ubuntu, Gentoo)
with same results.

Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the mono-bugs mailing list