[Mono-bugs] [Bug 687521] New: VS 2010 Debugger Detaches - Exit Code 255 (0xff)

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Thu Apr 14 08:57:38 EDT 2011



           Summary: VS 2010 Debugger Detaches - Exit Code 255 (0xff)
    Classification: Mono
           Product: MonoDroid
           Version: unspecified
          Platform: 64bit
        OS/Version: Windows 7
            Status: NEW
          Severity: Major
          Priority: P5 - None
         Component: Debugger
        AssignedTo: mkestner at novell.com
        ReportedBy: dennis.quebe at quebesystems.com
         QAContact: mono-bugs at lists.ximian.com
          Found By: ---
           Blocker: ---

User-Agent:       Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64;

When starting a debug session against the emulator, Visual Studio detaches the
debugger and exits with the following: 

“The program ‘Mono’ has exited with code 255 (0xff)”

The application in the emulator continues to run.

Reproducible: Always

Steps to Reproduce:
1. Get default image from Microsoft for Visual Studio 2010 in a Virtual Machine
2. Install Java 6 Update 24, Android SDK, Mono for Android
3. Create new project using template
4. Debug the project without any changes (make sure Output window is open)
5. Click the button about 50 times or just wait. 
6. See message in Output: “The program ‘Mono’ has exited with code 255 (0xff).”
Actual Results:  
“The program ‘Mono’ has exited with code 255 (0xff)”

Expected Results:  
Debugger should not detach.

Tried different editions of Visual Studio 2010, tried both 32-bit/64-bit
operating systems, tried older version of Java, and tried new installation of
development environment. The previous beta worked fine.

Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the mono-bugs mailing list