[Mono-bugs] [Bug 656103] Beta 3.2.1:Cannot open project in XCode. iOS 4.2

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Wed Dec 1 05:06:30 EST 2010



--- Comment #4 from Johan Otto <johan.otto at justenough.com> 2010-12-01 10:06:28 UTC ---
Hi Miguel,

I'm doing debug builds and the symptoms is similar to launching in XCode. It
doesn't seem to get as far as actually launching. It seems that the pdb/gdb
(debug files) generates C++ code that does not compile. I might be mistaken.

I am tremendously 'unclear' about the "trampolines" switch and have tried
different iterations and now have taken it out. It still doesn't get to a point
where the deploy window pops up and the error message is as greek as the one

My current options is 
Config: Debug, Platform: IPhone
YES Build debug-mode binaries
Linker behavior (Don't link) -- tried different settings, no affect
SDK version - Default -- tried 4.2 (have latest 4.2 iOS SDK installed and
latest MonoDevelop)
Minimum OS Version 4.2. -- tried different settings
Extra arguments: -v -v -v
- nothing else
* IPhone Bundle: Got my device provisioned, IPad has got my profile installed,
and my identity is set and profile selected.

Other stuff: Display name - JustEnough, Bundle ID - JustEnough Bundle version
1.0. I got a "Settings.bundle" directory and I use four projects, three are
just DLLs. These I can incorporate into one with lots of effort (shouldn't be
necessary right). 
References are set as project references. 
I use no thrid party Dlls, just monotouch, and the System dlls as well as
System.Web.Services... finally... lots of code at this stage, am stripping
stuff out but it's essentially an enterprise project for NetSuite

Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the mono-bugs mailing list