[Mono-bugs] [Bug 546603] runtime crash when exiting MonoDevelop on osx

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Sun Apr 18 08:30:56 EDT 2010



Sumit Khanna <sum.notify at gmail.com> changed:

           What    |Removed                     |Added
                 CC|                            |sum.notify at gmail.com

--- Comment #2 from Sumit Khanna <sum.notify at gmail.com> 2010-04-18 12:30:53 UTC ---
I might have something similar. I just installed Mono onto a MacOS 10.6.3
machine. I tried running one of my older applications which worked fine on my
10.5.x box and my Linux system, but on Mac I now get the following:

$ mono MplayerBuddy.exe 

Unhandled Exception: System.DllNotFoundException: libgtk-quartz-2.0.0.dylib
  at (wrapper managed-to-native) Gtk.Application:gtk_init (int&,intptr&)
  at Gtk.Application.Init () [0x00000] in <filename unknown>:0 
  at org.penguindreams.MplayerBuddy.MplayerBuddy.Main (System.String[] args)
[0x00000] in <filename unknown>:0 

I installed MonoFramework-2.6.3_4.macos10.novell.x86.dmg

I re-downloaded and installed it again just to make sure I didn't get a bad
install. It exited successfully both times. The application I was trying to
run, with source code, can be found here: 


Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.

More information about the mono-bugs mailing list