[Mono-bugs] [Bug 539394] mod_mono web app hangs when a cross-appdomain call results in a ThreadAbortException

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Fri Sep 25 11:59:41 EDT 2009


User brett at fogcreek.com added comment

Brett Kiefer <brett at fogcreek.com> changed:

           What    |Removed                     |Added
             Status|RESOLVED                    |REOPENED
         Resolution|FIXED                       |

--- Comment #11 from Brett Kiefer <brett at fogcreek.com>  2009-09-25 09:59:40 MDT ---
Thanks for clearing that up! Okay, I tried reverting your (Gonzalo's) patch and
applying Zoltan's patch from mono's svn r142389 (applied fine against
and rebuilt without a hitch). However, when I ran it against the redirecting
test app (the one from Comment #8 here), I got the following error:

System.Threading.ThreadAbortException: Thread was being aborted
  at FogCreek.FogBugz.HttpHandler.ProcessRequest (System.Web.HttpContext
context) [0x00000] 
  at System.Web.HttpApplication+<Pipeline>c__Iterator2.MoveNext () [0x00000] 
  at System.Web.HttpApplication.Tick () [0x00000] 

Are you saying that we need to _fully_ bump to a trunk build to confirm this
fix? Does the test app from Comment #8 work for you?

Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the mono-bugs mailing list