[Mono-bugs] [Bug 537283] New: Mono applications fail to access network

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Tue Sep 8 01:55:35 EDT 2009


           Summary: Mono applications fail to access network
    Classification: Mono
           Product: Mono: Class Libraries
           Version: 2.4.x
          Platform: x86-64
        OS/Version: SuSE Other
            Status: NEW
          Severity: Normal
          Priority: P5 - None
         Component: System
        AssignedTo: mono-bugs at lists.ximian.com
        ReportedBy: dave.plater at yahoo.co.uk
         QAContact: mono-bugs at lists.ximian.com
          Found By: ---

Description of Problem:Using monodevelop as an example, when starting it gives
the following error:-
WARNING [2009-09-08 06:58:27Z]: Welcome Page news file could not be downloaded.
System.Net.WebException: Error: ConnectFailure
  at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult)
  at System.Net.HttpWebRequest.GetResponse () [0x00000]
  at MonoDevelop.WelcomePage.WelcomePageView.updateNewsXmlThread () [0x00000]

Steps to reproduce the problem:
1.Start monodevelop from command line 

Actual Results:The above error message and the message in monodevelop window
saying that no news has been found.

Expected Results: Welcome page displayed in monodevelop

How often does this happen? 
All the time.

Additional Information: I have followed the instructions for Parallel Mono
Environments and compiled a fresh mono system and even removed the system mono
to be sure that it wasn't interfering and I still receive the same error.
MonoOsc works correctly in Virtualbox WinXp but fails with the same error on
host system.

Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.

More information about the mono-bugs mailing list