[Mono-bugs] [Bug 548168] Successive try/catch fails to trap errors on device

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Mon Oct 19 13:31:33 EDT 2009


User gcarrier at gmail.com added comment

--- Comment #1 from Gregory Carrier <gcarrier at gmail.com>  2009-10-19 11:31:23 MDT ---
Created an attachment (id=323091)
 --> (http://bugzilla.novell.com/attachment.cgi?id=323091)
Entire app project that demonstrates the blowup.

I am not directly handling NS objects other than using the two function calls
referenced in the bug.  However, since I used Interface Builder to create UI
objects that I am assigning to, that might be the combination of errors that
you need to cause the failure of the try statement to contain/control the

I thought I was done with this project, just awaiting the icons before
submitting the app.  The app worked fine on simulator and device before I added
more than the first store/retrieval (i.e. the first store/retrieve worked fine
on simulator and device).  After I got all my store/retrieves working on the
simulator is when I discovered that it no longer worked on the device.

Feel free to peruse the project:
1) To see how ignorant users abuse your system
2) The load performance is awful, even without the fetching of stored variables
3)  Feel free to suggest better ways that I do something


Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the mono-bugs mailing list