[Mono-bugs] [Bug 516323] xbuild can't handle enum properties in tasks

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Thu Jun 25 08:06:37 EDT 2009


User jankit at novell.com added comment

Ankit Jain <jankit at novell.com> changed:

           What    |Removed                     |Added
             Status|ASSIGNED                    |RESOLVED
         Resolution|                            |INVALID

--- Comment #1 from Ankit Jain <jankit at novell.com>  2009-06-25 06:06:36 MDT ---
I tried as task with a enum type property, but msbuild doesn't seem to like it.
I tried with full name (EnumName.ItemName) also, but msbuild doesn't take it as
an valid value. 

This is what i tried:

                <EnumTestTask Property="TestEnum.First">
                        <Output TaskParameter='Property' ItemName='I0' />

enum TestEnum { First }

I tried with Property="First" also.

If you think I'm doing it wrong and can get me a working test case, then please
re-open this bug. Closing this as INVALID.

Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the mono-bugs mailing list