[Mono-bugs] [Bug 498507] mono _sometimes_ doesn't throw ObjectDisposedException when calling socket.Close()

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Wed Apr 29 11:46:05 EDT 2009


User gonzalo at novell.com added comment

Gonzalo Paniagua Javier <gonzalo at novell.com> changed:

           What    |Removed                     |Added
             Status|REOPENED                    |RESOLVED
         Resolution|                            |FIXED

--- Comment #8 from Gonzalo Paniagua Javier <gonzalo at novell.com>  2009-04-29 09:46:04 MDT ---
The above comment is the *exact* test I tried on a linux/x86 AND two other
people tried on their Macs.

The output is something like:
** (sock.exe:59145): Warning **: _wapi_connect: error looking up socket handle

in ALL the cases.

Perhaps this was fixed after 2.2.x, but it works just fine with 2.4 and HEAD
(apart from the warning, which I'm taking care of now).

Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.

More information about the mono-bugs mailing list