[Mono-bugs] [Bug 494275] send zero-sized buffer to Socket doesn't send empty tcp packet

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Tue Apr 21 01:59:58 EDT 2009


User vsevolodp at gmail.com added comment

--- Comment #6 from Vsevolod Parfenov <vsevolodp at gmail.com>  2009-04-20 23:59:58 MDT ---
And it is still a question of compatibility. I've found this difference when i
try to test my server under suse with mono (calling "mono server.exe"). Code
was working with ms library (in some situations as i see now) and stopped to
catch connection brake with mono library.
When someone will port app to mono he will find this difference as mono bug.
Probably he will not know about poll method and will do what msdn says. And
under mono his code will work not how he expected.
In the other side that will be the reason to find out Poll method :)

I've tried both methods. Poll is more reliable. Thanks!

But still doesn't work when i check connection to mobile device.
That's what i do:
1) connect GSM-modem to server via GPRS
2) server accepts connection and poll it every second
3) i switch off GSM-modem but server don't see that connection disappeared

Can you advise something except of sending real data and wait for real answer
to check connection in this situation? GPRS traffic is quite expensive.

Configure bugmail: http://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the mono-bugs mailing list