[Mono-bugs] [Bug 368885] New: make install puts the System.dll, System.Core.dll, and System.Xml.Core.dll in the wrong place

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Mon Mar 10 22:03:10 EDT 2008


           Summary: make install puts the System.dll, System.Core.dll, and
                    System.Xml.Core.dll in the wrong place
           Product: Mono: Class Libraries
           Version: SVN
          Platform: x86
        OS/Version: Windows Vista
            Status: NEW
          Severity: Normal
          Priority: P5 - None
         Component: System
        AssignedTo: mono-bugs at lists.ximian.com
        ReportedBy: davecferguson at gmail.com
         QAContact: mono-bugs at lists.ximian.com
          Found By: Development

Description of Problem:

When running 'make install' from the cygwin prompt after compiling, the
System.dll, System.Core.dll, and System.Xml.Core.dll are installed into the
wrong directory tree.  Instead of using the /usr/local from the / root of my
cygwin install (in this case, it is C:\Dev\cygwin, my mono src is in
C:\Dev\mono-src\mono) the 'make install' placed the files in
C:\usr\local\lib\mono\, C:\usr\local\lib\mono\2.1, and

Steps to reproduce the problem:
1. I followed Shana's guide to getting mono compiling on both my Windows
workstations and my linux workstation
2. I configured my cygwin install to be at root in C:\Dev\cygwin.
3. I created a symbolic link in my cygwin root to /cygdrive/c/Dev
4. I downloaded (using svn co) the source to /dev/mono-src
5. I ran the autogen.sh --prefix=/usr/local in the /mono dir in the source tree
6. I ran make, the src compiled
7. I ran make install, the libraries were installed.  The above mentioned were
not in C:\Dev\cygwin\usr\local\<insert respective dir && filename>.  Other
files were in the appropriate spot in the 2.1 folder.

Actual Results:

I ran this on 3/2 and the files were placed in the wrong location on both my
Vista 32 and Vista 64 workstations.

Expected Results:

The files should be placed in the proper location by 'make install'.  In this
case, it should be /usr/local/ (which is at C:\Dev\cygwin\usr\local).  Instead
it was C:\usr\local

How often does this happen? 


Additional Information:

These were fresh installs of cygwin as well.

Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.

More information about the mono-bugs mailing list