[Mono-bugs] [Bug 362930] New: MySql Connector/NET Issues

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Tue Feb 19 09:14:49 EST 2008


           Summary: MySql Connector/NET Issues
           Product: Mono: Class Libraries
           Version: unspecified
          Platform: Sparc
        OS/Version: Solaris 10
            Status: NEW
          Severity: Major
          Priority: P5 - None
         Component: Sys.Data
        AssignedTo: bnc-blr-team-mono at forge.provo.novell.com
        ReportedBy: soizic.roquier at cg44.fr
         QAContact: mono-bugs at lists.ximian.com
          Found By: ---

I am trying to get a console application compiled with .NET 1.1 that  
uses the MySql Connector/NET to work correctly. I have tried 1.0.9 and
of the connector and installed them in the GAC on a  
Solaris 10 box running Mono 1.2.4_4. I have also compiled this application with
NET 2.0 and MySQL connector/NET 5.2.0. I have put it on my Solaris server with
the MySQL Connector/NET 5.2.0 in the GAC but it doesn't work.
The console application I am  
running is just a test console app to make sure I can connect to the  
database so all it does is call MySqlConnection.Open.
The same application works fine on a SLES 10 environment with mono 1.2.6.

On my Solaris platform, I have also tried localhost and for the
server. The following is the error message I receive:

MySql.Data.MySqlClient.MySqlException: Unable to connect to any of the
specified MySQL hosts. ---> System.Exception: Exception of type
System.Exception was thrown.
  at MySql.Data.MySqlClient.NativeDriver.Open () [0x00000] --- End of inner
exception stack trace ---

  at MySql.Data.MySqlClient.NativeDriver.Open () [0x00000] 
  at MySql.Data.MySqlClient.Driver.Create
(MySql.Data.MySqlClient.MySqlConnectionString settings) [0x00000] 
  at MySql.Data.MySqlClient.MySqlPool.CreateNewPooledConnection () [0x00000] 
  at MySql.Data.MySqlClient.MySqlPool.GetPooledConnection () [0x00000] 
  at MySql.Data.MySqlClient.MySqlPool.GetConnection () [0x00000] 
  at MySql.Data.MySqlClient.MySqlConnection.Open () [0x00000] 

Can you help me, please ?



Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the mono-bugs mailing list