[Mono-bugs] [Bug 384485] New: On OpenSUSE 10.3/Linux, SerialPort.Open always fails.

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Mon Apr 28 15:17:28 EDT 2008


           Summary: On OpenSUSE 10.3/Linux,SerialPort.Open always fails.
           Product: Mono: Class Libraries
           Version: 1.9.0
          Platform: i686
        OS/Version: openSUSE 10.3
            Status: NEW
          Severity: Blocker
          Priority: P5 - None
         Component: Sys.Core
        AssignedTo: mono-bugs at lists.ximian.com
        ReportedBy: cwalker at controlthink.com
         QAContact: mono-bugs at lists.ximian.com
          Found By: Third Party Developer/Partner

Chris Walker <cwalker at controlthink.com> changed:

           What    |Removed                                         |Added
               Flag|                                                |SHIP_STOPPER?, CCB_Review?

Under Linux (OpenSUSE 10.3 for test case), Mono 1.9.0/1 fails to open serial
port under all test cases.

OpenSUSE 10.3 w/ Mono 1.9.0 (also tested and fails with official "Live CD")

Expected behavior:
System.IO.Ports.SerialPort(.Open) should open the serial port.

Worked in:
Recently broken; worked in older Linux/Mono releases.

Other notes:
This fails with built-in com ports and two different Serial USB adapters.  The
hardware is a Latitude D620 with 2GB RAM.

Sample source code (Main.cs):
---8<---8<---cut here--->8--->8--- 
using System;
using System.IO.Ports;

namespace SerialPortTest
        class MainClass
                public static void Main(string[] args)
                        Console.WriteLine("1. Creating SerialPort object...");
                        SerialPort serialPort = new SerialPort("/dev/ttyS0");
                        Console.WriteLine("2. Opening SerialPort...");
                        Console.WriteLine("3. Success.");
---8<---8<---cut here--->8--->8---

Application Output (using MonoDevelop 1.0):
1. Creating SerialPort object...
2. Opening SerialPort...

Unhandled Exception: System.IO.IOException: I/O Error
  at System.IO.Ports.SerialPortStream..ctor (System.String portName, Int32
baudRate, Int32 dataBits, Parity parity, StopBits stopBits, Boolean dtrEnable,
Boolean rtsEnable, Handshake handshake, Int32 readTimeout, Int32 writeTimeout,
Int32 readBufferSize, Int32 writeBufferSize) [0x00075] in
  at (wrapper remoting-invoke-with-check)
  at System.IO.Ports.SerialPort.Open () [0x00078] in
  at (wrapper remoting-invoke-with-check) System.IO.Ports.SerialPort:Open ()
  at SerialPortTest.MainClass.Main (System.String[] args) [0x0001f] in

Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.

More information about the mono-bugs mailing list