[Mono-bugs] [Bug 81219][Wis] Changed - DrawString: Unknown char "box" not rendered for \u0000

bugzilla-daemon at bugzilla.ximian.com bugzilla-daemon at bugzilla.ximian.com
Tue Mar 27 17:40:44 EDT 2007

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by sebastien at ximian.com.


--- shadow/81219	2007-03-23 23:47:41.000000000 -0500
+++ shadow/81219.tmp.30431	2007-03-27 16:40:44.000000000 -0500
@@ -1,13 +1,13 @@
 Bug#: 81219
 Product: Mono: Class Libraries
 Version: unspecified
 OS: unknown
 OS Details: 
-Status: NEW   
+Status: RESOLVED   
+Resolution: NOTABUG
 Severity: Unknown
 Priority: Wishlist
 Component: libgdiplus
 AssignedTo: mono-bugs at ximian.com                            
 ReportedBy: jackson at ximian.com               
 QAContact: mono-bugs at ximian.com
@@ -31,6 +31,108 @@
 ------- Additional Comments From jackson at ximian.com  2007-03-23 23:47 -------
 The format stuff shouldn't really change anything.  I just left that
 in my test case, since it was my first guess as to what might be wrong.
+------- Additional Comments From sebastien at ximian.com  2007-03-27 16:40 -------
+The "box" is dependent on the font. The box shows on "normal" XP
+because there's no glyph #0 present in Arial. However if you have the
+large (30mb) universal font, then unknown glyphs will be taken from
+it, and no box will be shown.
+Discussion (edited)
+<jackson> spouliot, pretty sure, does it not do that for you?
+<spouliot> because on my XP box I don't get the box
+<spouliot> it may be font specific, but Arial should be pretty standard :|
+<jackson> yeah, i just downloaded / compiled and ran it on windows and
+i get the box
+<jackson> spouliot, it could be a lang thing too?
+<spouliot> jackson: maybe if you're not using US-en
+<jackson> oh, i am using that
+<jackson> spouliot, what .net version are you using?
+<spouliot> tried 1.1 right now, trying 2.0...
+<jackson> I have been trying with 2.0
+<spouliot> no box on 2.0
+<rolf> jackson, spouliot: I do get the box on XP
+<spouliot> rolf: no, I don't
+<jackson> so rolf and i get it, spouliot doesnt.....i wonder why
+<rolf> spouliot, did you compile with mcs?
+<spouliot> I do get a quarter box (upper left) if I change \u0000 to
+<spouliot> rolf: csc (7.1 and 8.0)
+<rolf> doesn't matter, I get the box anyway
+<rolf> compiled with csc and mcs and gmcs
+<jackson> yeah i get the full box for \u0001 also
+<spouliot> Zhila: ah, right. don't try my memory too hard today
+<jackson> Zhila, knock it off, you are making things extra confusing ;-)
+<spouliot> jackson: \u0002 is another quarter
+<jackson> spouliot, still a box for me at \u0002
+<jackson> it sounds like you have better fonts then me
+<jackson> spouliot, is that with the arial font thing still in there,
+or did you comment it out?
+<spouliot> I didn't comment anything
+<jackson> either way (with or without the font being set to arial) I
+get a box for 0000, 0001, and 0002
+<rolf> I commented out the font and formatting stuff and I get boxes
+up to \u0009
+<spouliot> well I tried to comments stuff earlier but didn't get the
+box, so I gradually got back to the original sample
+<jackson> well, i guess no matter what, this means I can't use
+DrawString ("\u0000") to get that box
+<spouliot> ok, I have an idea. I think I have installed the large MS
+universal font (>30 mb)
+<rolf> tried DrawString("box")?
+<spouliot> so I could see SPAM in it's original form ;-)
+<jackson> i was just checking windows update for something like that
+<jackson> haha
+<rolf> I guess that wouldn't be culture-aware though...
+<spouliot> rolf: I wouldn't expect it to change the way Arial works
+:-| but maybe it defaults "missing" glyphs into that large font ?
+<rolf> spouliot, I think I read somewhere that missing glyphs are
+drawn with those rectangles 
+<rolf> a very long time ago...
+<rolf> I used to get them whenever a japanese / korean / chinese popped up
+<spouliot> rolf: it reminds me of something too
+<jackson> ok, well does anyone know a way that i can draw that box
+predictibly?  I need to draw that when a user has line feeds but they
+are in non multiline mode
+<rolf> doesn't "\u0013' or '\u0010' work?
+* spouliot is not sure the current code can detect between a space and
+a missing glyph
+<jackson> oh \u0013 does work
+<jackson> I guess I only tried with line feed, not carriage return
+<spouliot> on my XP it shows '!!', and on linux I miss both left and
+right lines
+<jackson> oh my
+<spouliot> but I guess it's trying to draw a box
+<spouliot> jackson: does it show up correctly for you on linux ?
+<rolf> spouliot, did you try changing the font to something else?
+<jackson> \u0013 does
+<spouliot> rolf: same thing with Courrier
+<jackson> maybe we should close the bug "behavior unpredictable" 
+<spouliot> I think the large font acts as a default
+<jackson> yeah, that is probably what happens
+<rolf> I don't get any box for 10 or 13 on linux...
+<jackson> I do for 13 but not 10
+<rolf> I suppose it depends on the font I have installed :)
+<jackson> yeah
+<rolf> I don't think you'll need anything special, just draw
+whatever's there (10 or 13)
+<jackson> well, as long as it works on gerts machine, i can close the
+bug :)
+<rolf> I'd close the bug report with: "it only works like this on MS
+if you don't have a decent font installed"
+<rolf> that's closer to those areas, isn't it?
+<spouliot> rolf: good point, if it's the case !?!
+<rolf> well, I suppose only you have a decent font installed, and only
+you can't reproduce it...
+<spouliot> jackson: want me to try the original bug report ? to see if
+there's a box or not shown ?
+<jackson> i guess we can close it, since its really just font differences
+<spouliot> well 81219 is, but the original one may not be
+<jackson> spouliot, http://bugzilla.ximian.com/show_bug.cgi?id=79799
+<jackson> yeah, the original will probably still show the boxes for you
+<spouliot> I don't see box when using the instructions

More information about the mono-bugs mailing list