[Mono-bugs] [Bug 80642][Wis] New - gmcs.exe can't compile the same code it did in

bugzilla-daemon at bugzilla.ximian.com bugzilla-daemon at bugzilla.ximian.com
Fri Jan 26 21:19:01 EST 2007

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by awaddell at fnfr.com.


--- shadow/80642	2007-01-26 21:19:00.000000000 -0500
+++ shadow/80642.tmp.31400	2007-01-26 21:19:01.000000000 -0500
@@ -0,0 +1,43 @@
+Bug#: 80642
+Product: Mono: Compilers
+Version: 1.2
+OS: All
+OS Details: 
+Status: NEW   
+Priority: Wishlist
+Component: C#
+AssignedTo: rharinath at novell.com                            
+ReportedBy: awaddell at fnfr.com               
+QAContact: mono-bugs at ximian.com
+TargetMilestone: ---
+Summary: gmcs.exe can't compile the same code it did in
+I've just tried the 1.2.3 preview and it's having trouble compiling our
+application. compiles exactly the same code fine.  I've been
+trying to reproduce it with smaller test case (smaller than our entire
+build), but I haven't been able to reproduce it.  Unfortunately, I only
+have this for you to go on (see error below).  The class it's complaining
+about is definitely there and as I say, if I do nothing other than switch
+to, it works.  The DocumentDeserializationContext is in a different
+assembly which is getting pulled in with a -reference (in projrefs.txt).  I
+tried a trival piece of code linked to the same assembly and it worked
+fine.  I'm hoping you can review your chages to gmcs.exe between
+and now or something like that.  I tried it on Linux with the same results.
+Let me know if I can help.
+    "C:\Program Files\Mono-1.2.3\bin\gmcs" /noconfig
+/nowarn:1691,67,169,278 /warnaserror+  /warn:4 /define:TRACE;DEBUG
+/define:MONO;HEADLESS;FIXME /reference:System;System.Data;System.Xml
+/out:mono\Debug\ffsvt.exe /target:exe @C:\svt\SvtClient\ffsvt\projrefs.txt
+ at C:\svt\SvtClient\ffsvt\resources.txt  @C:\svt\SvtClient\ffsvt\compile.txt
+    RsvtBrokerPartialStep.cs(30,51): error CS0246: The type or namespace
+name `DocumentDeserializationContext' could not be found. Are you missing a
+using directive or an assembly reference?
+    Compilation failed: 1 error(s), 0 warnings

More information about the mono-bugs mailing list