[Mono-bugs] [Bug 346563] New: Mono.Addins 0. 2 does not function correctly on deployment platform

bugzilla_noreply at novell.com bugzilla_noreply at novell.com
Thu Dec 6 11:42:27 EST 2007


           Summary: Mono.Addins 0.2 does not function correctly on
                    deployment platform
           Product: Mono: Class Libraries
           Version: unspecified
          Platform: IA64
        OS/Version: SLES 10
            Status: NEW
          Severity: Critical
          Priority: P5 - None
         Component: Mono.Addins
        AssignedTo: lluis at novell.com
        ReportedBy: jo.shields at oerc.ox.ac.uk
         QAContact: mono-bugs at ximian.com
          Found By: Customer

My application is unable to correctly function on my deployment platform, and
throws out multiple errors of the form:
ERROR: Could not read folder info file (Array index is out of range.)

I've isolated where the error is being caused - it's in my code, when
initializing, I run the following:

   AddinManager.Initialize( );
   AddinManager.Registry.Update( null );

After the second line, all further calls to Mono.Addins (e.g. using the mautil
utility) are broken, and display the same error.

This code functions fine on test platforms (Ubuntu x86-64 7.10 Mono 1.2.4,
Windows Vista i386 MS.net 2.0, Debian x86-64 4.0 Mono 1.2.2), it will not
function on the deployment platform (SLES IA64 10 Mono 1.2.2, tested with as well)

Configure bugmail: https://bugzilla.novell.com/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.

More information about the mono-bugs mailing list