[Mono-bugs] [Bug 82484][Maj] New - [zmd] Exception in remoting call when trying to run updates

bugzilla-daemon at bugzilla.ximian.com bugzilla-daemon at bugzilla.ximian.com
Sun Aug 19 00:31:20 EDT 2007

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by twiest at novell.com.


--- shadow/82484	2007-08-19 00:31:20.000000000 -0400
+++ shadow/82484.tmp.14002	2007-08-19 00:31:20.000000000 -0400
@@ -0,0 +1,64 @@
+Bug#: 82484
+Product: Mono: Class Libraries
+Version: 1.2
+OS Details: openSUSE 10.2 i386
+Status: NEW   
+Priority: Major
+Component: CORLIB
+AssignedTo: mono-bugs at ximian.com                            
+ReportedBy: twiest at novell.com               
+QAContact: mono-bugs at ximian.com
+TargetMilestone: ---
+Summary: [zmd] Exception in remoting call when trying to run updates
+Description of Problem:
+When trying to run updates as a non-root user using mono 1.2.5p4, ZMD dies
+saying Exception in remoting call.
+Steps to reproduce the problem:
+1. Install openSUSE 10.2 i386 with the default apps
+2. DO NOT install any updates
+3. Upgrade to mono 1.2.5p4 from here:
+   http://mono.ximian.com/monobuild/preview/download-preview/suse-102-i586/
+4. reboot the computer
+5. Login to the gui as a normal user
+6. Wait for the zen-updater icon to turn into an exclamation point
+7. Click on the Exclamation point
+8. The updater will say that there are ~123 updates, however zen-updater
+will only show 1 update to libzypp (I think this is supposed to happen)
+9. Click "Update" to install the libzypp update
+10. Add your non-root user as a privileged user of ZMD
+11. Click "Apply" on the Change Summary dialog
+12. Click "Close" on the "update was successful" dialog
+13. Notice that now the list of updates contains the other ~122 updates. 
+14. Click "Update"
+15. Notice that zen-updater just sits there on "Resolving Dependencies"
+Actual Results:
+zen-updater just sits there on resolving dependencies forever. I let it sit
+for > 3 hours and it never pop-ed up the list of dependencies (this step
+takes < 2 minutes on
+In the zmd-messages log file it says:
+Exception in remoting call
+and then it seems that ZMD gets restarted.
+Expected Results:
+It should resolve the deps and install them
+How often does this happen? 
+Everytime IF above procedure is followed. It works if you run it as root.
+Additional Information:
+Works on (tried it twice)
+Fails on 1.2.4 (tried it once)
+Fails on 1.2.5p4 (tried it three times)

More information about the mono-bugs mailing list