[Mono-bugs] [Bug 82442][Wis] New - Mono svn head (r84118, also r83139) fails to compile on windows during mcs bootstrap

bugzilla-daemon at bugzilla.ximian.com bugzilla-daemon at bugzilla.ximian.com
Tue Aug 14 18:50:18 EDT 2007

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by mattj at google.com.


--- shadow/82442	2007-08-14 18:50:18.000000000 -0400
+++ shadow/82442.tmp.23943	2007-08-14 18:50:18.000000000 -0400
@@ -0,0 +1,47 @@
+Bug#: 82442
+Product: Mono: Compilers
+Version: 1.2
+OS: Windows XP (Cygwin)
+OS Details: 
+Status: NEW   
+Priority: Wishlist
+Component: C#
+AssignedTo: rharinath at novell.com                            
+ReportedBy: mattj at google.com               
+QAContact: mono-bugs at ximian.com
+TargetMilestone: ---
+Summary: Mono svn head (r84118, also r83139) fails to compile on windows during mcs bootstrap
+mcs generates the following stacktrace during compilation:
+make[7]: Entering directory `/home/mattj/mcs/mcs'
+mcs /codepage:65001  /nologo /optimize -d:NET_1_1 -d:ONLY_1_1
+-d:BOOTSTRAP_WITH_OLDLIB /debug+ /debug:full -target:exe -out:mcs.exe
+cs-parser.cs  @../build/deps/mcs.exe.response
+warning CS8018: Could not find the symbol writer assembly
+(Mono.CompilerServices.SymbolWriter.dll). This is normally an installation
+problem. Please make sure to compile and install the
+mcs/class/Mono.CompilerServices.SymbolWriter directory.
+Unhandled Exception: System.InvalidOperationException: Underlying type
+information on enumeration is not specified.
+   at System.Reflection.Emit.TypeBuilder.get_UnderlyingSystemType()
+   at System.Type.GetHashCode()
+   at System.Collections.Hashtable.GetHash(Object key)
+   at System.Collections.Hashtable.Insert(Object key, Object nvalue,
+Boolean add)
+   at System.Collections.Hashtable.Add(Object key, Object value)
+   at Mono.CSharp.TypeContainer.CreateTypeBuilder()
+   at Mono.CSharp.TypeContainer.CreateType()
+   at Mono.CSharp.TypeContainer.CreateType()
+   at Mono.CSharp.RootContext.ResolveTree()
+   at Mono.CSharp.Driver.MainDriver(String[] args)
+   at Mono.CSharp.Driver.Main(String[] args)
+I'm building this using the stock Mono 1.2.4 install (verified by running
+mono --version). If I run 'make -k' everything else builds fine. I've tried
+building / installing the SymbolWriter dll, but this doesn't fix it.

More information about the mono-bugs mailing list