[Mono-bugs] [Bug 82438][Wis] New - Mono for Windows 1.2.4 failing to start on wine 0.9.42

bugzilla-daemon at bugzilla.ximian.com bugzilla-daemon at bugzilla.ximian.com
Tue Aug 14 08:09:20 EDT 2007

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by matt.drew at gmail.com.


--- shadow/82438	2007-08-14 08:09:20.000000000 -0400
+++ shadow/82438.tmp.4828	2007-08-14 08:09:20.000000000 -0400
@@ -0,0 +1,68 @@
+Bug#: 82438
+Product: Mono: Runtime
+Version: 1.2
+OS Details: Gentoo, wine
+Status: NEW   
+Priority: Wishlist
+Component: misc
+AssignedTo: mono-bugs at ximian.com                            
+ReportedBy: matt.drew at gmail.com               
+QAContact: mono-bugs at ximian.com
+TargetMilestone: ---
+Summary: Mono for Windows 1.2.4 failing to start on wine 0.9.42
+Please fill in this template when reporting a bug, unless you know what you
+are doing.
+Description of Problem:
+I've installed Mono for Windows on wine 0.9.42 in an attempt to get a game
+working (more specifically, the NCSoft Launcher, a .Net 2.0 application). 
+The installer appeared to complete normally.  Unfortunately, something
+pretty basic appears to be wrong, as mono does not initialize. Instead, it
+dies with a blank stack trace.  I cannot complete the "OK" script on the
+mono website, as mcs.exe does not run.
+There's a debug trace here:
+that shows the gist of it.  Essentially, mono tries to open several core
+Windows DLLs (kernel32.dll, user32.dll, etc) from its own directory
+(C:\Program Files\Mono-1.2.4\lib\mono\2.0) and then dies after trying to
+open mscorlib.dll.dll and mscorlib.dll.dll.la - neither of which exist.
+I'm using Gentoo, so I can give you any build information you want on the
+underlying platform.  Two other people have tried this that I know of, and
+both had the same failure.
+Steps to reproduce the problem:
+1. install wine-0.9.42 on Linux
+2. install mono-1.2.4 for Windows into wine (wine
+3. attempt to run any mono executable (WINEDEBUG=+relay,+seh,+dll will get
+you the same trace info as in the wine bug)
+Actual Results:
+Mono exits with a crash and a blank stack trace.
+Expected Results:
+Mono initializes enough to get trace information from Mono itself to
+further debug the app I'm trying to run.
+How often does this happen? 
+Every time.
+Additional Information:
+I tried copying the dlls mono was looking for to mono's 2.0 directory.  It
+appeared to open them alright, but it still crashed after trying to open
+mscorlib.dll.dll.la (which, of course, does not exist).  I also tried
+manipulating the PATH to no effect.

More information about the mono-bugs mailing list