[Mono-bugs] [Bug 79895][Nor] Changed - Can't install Mono 1.2 because of circular dependencies

bugzilla-daemon at bugzilla.ximian.com bugzilla-daemon at bugzilla.ximian.com
Fri Nov 10 17:23:04 EST 2006

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by mickaelpic at yahoo.fr.


--- shadow/79895	2006-11-10 16:45:48.000000000 -0500
+++ shadow/79895.tmp.18345	2006-11-10 17:23:04.000000000 -0500
@@ -1,13 +1,13 @@
 Bug#: 79895
 Product: Mono: Class Libraries
 Version: 1.0
 OS: other
 OS Details: Red Hat Linux Enterprise 4.0 x86
-Status: RESOLVED   
-Resolution: FIXED
+Status: REOPENED   
 Severity: Unknown
 Priority: Normal
 Component: Sys.Web
 AssignedTo: wberrier at novell.com                            
 ReportedBy: mickaelpic at yahoo.fr               
 QAContact: mono-bugs at ximian.com
@@ -59,6 +59,25 @@
 Unpack them all and then do:
 rpm -Uvh *.rpm
 I just tested an upgrade from to 1.2 using this method
 without any problems.
+------- Additional Comments From mickaelpic at yahoo.fr  2006-11-10 17:23 -------
+Sorry but your solution is not working.
+I just tried and it failed.
+I have removed all rpms first, and tried rpm -Uvh *.rpms and it 
+error: Failed dependencies:
+        mono(NAnt.Core) = 0.85.2344.0 is needed by
+        mono(NAnt.DotNetTasks) = 0.85.2344.0 is needed by
+        httpd is needed by mod_mono-1.1.18-0.rhel4.novell.i386
+    Suggested resolutions:
+        httpd-2.0.52-19.ent.i386.rpm
+And try to remove the packages without --nodeps and it will also fails
+You solution might work, ubt for updates only, not for a clean 

More information about the mono-bugs mailing list