[Mono-bugs] [Bug 78596][Min] Changed - Certain remoting server functionality fails on PCs with dual network cards

bugzilla-daemon at bugzilla.ximian.com bugzilla-daemon at bugzilla.ximian.com
Sat Jul 15 16:29:00 EDT 2006

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by miguel at ximian.com.


--- shadow/78596	2006-06-07 06:01:20.000000000 -0400
+++ shadow/78596.tmp.26203	2006-07-15 16:29:00.000000000 -0400
@@ -1,15 +1,15 @@
 Bug#: 78596
 Product: Mono: Runtime
 Version: 1.1
 OS: Red Hat 9.0
 OS Details: 
-Status: NEW   
+Status: REOPENED   
 Severity: Unknown
-Priority: Normal
+Priority: Minor
 Component: remoting
 AssignedTo: lluis at ximian.com                            
 ReportedBy: admin at svwebhosting.com               
 QAContact: mono-bugs at ximian.com
 TargetMilestone: ---
@@ -67,6 +67,45 @@
 Bind to the specific IP address and set the channel
 property useIpAddress="true".
 [changed prio]
+------- Additional Comments From lluis at ximian.com  2006-06-07 14:45 -------
+Closing since this is a problem in the configuration file.
+------- Additional Comments From admin at svwebhosting.com  2006-06-07 23:16 -------
+I just tried with useIpAddress="true" and I get the same error.
+I just found out it also doesn't work on servers with one network card
+and multiple IPs.
+This is what I did to duplicate it on PCs with 1 network card:
+- I configured a secondary ip.
+eth0 is
+eth0:0 is
+- I modified ProcessActivator.exe.config to bind to and
+- I modified the RemotingServer key on
+ProcessActivatorClient.exe.config to
+- I opened a SSH console and started the server:
+mono ProcessActivator.exe
+- I opened another SSH console and started the client:
+mono ProcessActivatorClient.exe
+- This is the output I get on the client:
+Test 1 (Returns bool)
+Test 2 (Returns IProcessActivator)
+2- ERROR: Error: ConnectFailure
+Using a packet sniffer I see it's still using the primary ip (eth0)
+<item id="ref-15"></item>
+------- Additional Comments From miguel at ximian.com  2006-07-15 16:29 -------
+Setting to minor, as this seems like a configuration problem. 

More information about the mono-bugs mailing list