[Mono-bugs] [Bug 77584][Blo] Changed - Configuration option for libapr directory

bugzilla-daemon at bugzilla.ximian.com bugzilla-daemon at bugzilla.ximian.com
Sun Feb 19 07:11:30 EST 2006

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by zac at zacbowling.com.


--- shadow/77584	2006-02-19 06:40:59.000000000 -0500
+++ shadow/77584.tmp.6086	2006-02-19 07:11:30.000000000 -0500
@@ -51,6 +51,103 @@
 ------- Additional Comments From gonzalo at ximian.com  2006-02-17 19:31 -------
 mod_mono has a configure flag to point to apr-config, which should
 provide the right include directory. Use ./configure
+------- Additional Comments From zac at zacbowling.com  2006-02-19 07:11 -------
+I ran this debian sarge, debian testing, and ubuntu horay and got the
+same result. 
+# ./configure --with-apr-config=/usr/bin/apr-config --prefix=/usr
+The mod_mono debian package appends on ' --with-apxs=/usr/bin/apxs2 '
+but trying to compile with that instead doesn't fix it either.
+At the end of the configuration I get this.
+Configuration summary for mod_mono
+   * Installation prefix = /usr
+   * Apache version = 2.0
+   * Apache modules directory = /usr/lib/apache2/modules
+   * apxs = /usr/bin/apxs2
+   * apr-config = /usr/bin/apr-config
+   * Verbose logging (debug) = no
+   * mono prefix = /usr/lib/pkgconfig/../..
+   * Default MonoApplicationsConfigDir =
+The make errors: 
+Making all in src
+make[1]: Entering directory `/home/zbowling/mono/trunk/mod_mono/src'
+if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I.
+-I. -I../include   -g -O2 -I/usr/include/apache2 -DLINUX=2
+-DDFLT_MONO_CONFIG_DIR=\"/etc/apache2/mod-mono-applications\" -g -O2
+-I/usr/include/apache2 -pipe -I/usr/include/xmltok
+-I/usr/include/openssl -Wall -g -O2 -pthread -MT
+mod_mono_la-mod_mono.lo -MD -MP -MF ".deps/mod_mono_la-mod_mono.Tpo"
+-c -o mod_mono_la-mod_mono.lo `test -f 'mod_mono.c' || echo
+'./'`mod_mono.c; \
+        then mv -f ".deps/mod_mono_la-mod_mono.Tpo"
+".deps/mod_mono_la-mod_mono.Plo"; else rm -f
+".deps/mod_mono_la-mod_mono.Tpo"; exit 1; fi
+ gcc -DHAVE_CONFIG_H -I. -I. -I../include -g -O2
+-I/usr/include/apache2 -DLINUX=2 -D_REENTRANT -D_XOPEN_SOURCE=500
+-DDFLT_MONO_CONFIG_DIR=\"/etc/apache2/mod-mono-applications\" -g -O2
+-I/usr/include/apache2 -pipe -I/usr/include/xmltok
+-I/usr/include/openssl -Wall -g -O2 -pthread -MT
+mod_mono_la-mod_mono.lo -MD -MP -MF .deps/mod_mono_la-mod_mono.Tpo -c
+mod_mono.c  -fPIC -DPIC -o .libs/mod_mono_la-mod_mono.o
+In file included from /usr/include/apache2/httpd.h:30,
+                 from mod_mono.h:48,
+                 from mod_mono.c:32:
+/usr/include/apache2/ap_config.h:20:17: error: apr.h: No such file or
+/usr/include/apache2/ap_config.h:21:23: error: apr_hooks.h: No such
+file or directory
+/usr/include/apache2/ap_config.h:22:32: error: apr_optional_hooks.h:
+No such file or directory
+In file included from mod_mono.h:48,
+                 from mod_mono.c:32:
+/usr/include/apache2/httpd.h:35:25: error: apr_general.h: No such file
+or directory
+/usr/include/apache2/httpd.h:36:24: error: apr_tables.h: No such file
+or directory
+/usr/include/apache2/httpd.h:37:23: error: apr_pools.h: No such file
+or directory
+/usr/include/apache2/httpd.h:38:22: error: apr_time.h: No such file or
+/usr/include/apache2/httpd.h:39:28: error: apr_network_io.h: No such
+file or directory
+/usr/include/apache2/httpd.h:40:25: error: apr_buckets.h: No such file
+or directory
+....(trimmed of course)....
+Some other extra information:
+...# apr-config --includes
+ -I/usr/include/apr-0
+...# apr-config --cflags
+ -pipe -I/usr/include/xmltok -I/usr/include/openssl -Wall -g -O2 -pthread
+...# apr-config --version
+...# apxs -q INCLUDEDIR
+bash: apxs: command not found
+...# apxs2 -q INCLUDEDIR
+Without looking through the makefile (no time here to figure it out
+tonight), it looks like 'apr-config --includes' isn't added to the
+cflags but 'apr-config --cflags' is.

More information about the mono-bugs mailing list