[Mono-bugs] [Bug 77570][Nor] New - Segfault within the GC only when using the debugger

bugzilla-daemon at bugzilla.ximian.com bugzilla-daemon at bugzilla.ximian.com
Wed Feb 15 18:34:09 EST 2006

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by joeshaw at novell.com.


--- shadow/77570	2006-02-15 18:34:09.000000000 -0500
+++ shadow/77570.tmp.28170	2006-02-15 18:34:09.000000000 -0500
@@ -0,0 +1,93 @@
+Bug#: 77570
+Product: Mono: Debugger
+Version: 1.1
+OS Details: 
+Status: NEW   
+Priority: Normal
+Component: cli
+AssignedTo: martin at ximian.com                            
+ReportedBy: joeshaw at novell.com               
+QAContact: mono-bugs at ximian.com
+TargetMilestone: ---
+Summary: Segfault within the GC only when using the debugger
+Not sure if this is a runtime or a debugger issue.
+When trying to run Beagle's GUI settings program, I don't get very far
+before I hit a segfault in the GC code.  It happens even if I run with
+Using up-to-date mono, mcs, and debugger through r56895 on NLD 10 beta, i686.
+Here is the complete mdb output:
+$ LD_LIBRARY_PATH=/home/joe/build/mono/lib:$LD_LIBRARY_PATH
+PATH=/home/joe/build/mono/bin:$PATH ./beagle-settings.mdb
+*** Running uninstalled Settings.exe ***
+Mono Debugger
+(mdb) r
+Starting program: ./Settings.exe
+Could not find file
+Could not find file
+Could not find file
+Process @1 stopped at #0: 0xb7a2f73e in
+SettingsDialog.Main(System.String[])+0xe at
+  44            SettingsDialog settings = new SettingsDialog ();
+(mdb) c
+Could not find file
+Could not find file "/home/joe/build/mono/lib/mono/1.0/System.dll.mdb".
+Could not find file
+Process @1 received signal 11 at #0: 0x0810f2d3 in GC_push_all_eager+0x33
+at /home/joe/cvs/mono/libgc/mark.c:1468.
+1468    q = *p;
+(mdb) bt
+(*) #0: 0x0810f2d3 in GC_push_all_eager+0x33 at
+    #1: 0x0807d1e2 in debugger_gc_push_all_stacks+0x42 at
+    #2: 0x08110495 in GC_mark_some+0x1f5 at /home/joe/cvs/mono/libgc/mark.c:393
+    #3: 0x0810a71b in GC_stopped_mark+0x9b at
+    #4: 0x0810aa97 in GC_try_to_collect_inner+0x87 at
+    #5: 0x0810ae0c in GC_collect_or_expand+0x1ac at
+    #6: 0x0810b2cc in GC_allocobj+0xcc at /home/joe/cvs/mono/libgc/alloc.c:1126
+    #7: 0x0810dd7e in GC_generic_malloc_inner+0x9e at
+    #8: 0x0810de3f in GC_generic_malloc+0x5f at
+    #9: 0x0810e046 in GC_malloc+0x96 at /home/joe/cvs/mono/libgc/malloc.c:313
+    #10: 0x08096fb4 in mono_array_new_specific+0x114 at
+    #11: 0x080a0527 in ves_icall_Type_GetFields_internal+0x177 at
+    #12: 0xb7a3c98c in <(wrapper managed-to-native)
+(System.Reflection.BindingFlags,System.Type)>+0x2c at 6
+    #13: 0xb7a3c949 in
+System.MonoType.GetFields(System.Reflection.BindingFlags)+0x11 at
+    #14: 0xb7a3c6f8 in <Glade.XML:BindFields (object,System.Type)>+0x78 at 16
+    #15: 0xb7a3c667 in <Glade.XML:BindFields (object)>+0x17 at 5
+    #16: 0xb7a3c5e7 in <Glade.XML:Autoconnect (object)>+0x1f at 3
+    #17: 0xb7a2fb05 in SettingsDialog..ctor()+0xad at
+    #18: 0xb7a2f754 in SettingsDialog.Main(System.String[])+0x24 at
+I also tried with another program which shared some of the same code, and
+the stack trace was essentially the same at the lowest frames.  Both call
+mono_array_new_specific() before going into the GC.  With the other
+program, I believe it was happening when constructing a Hashtable.

More information about the mono-bugs mailing list