[Mono-bugs] [Bug 79207][Nor] Changed - Recent changes in AppDomain loading affect mono-service

bugzilla-daemon at bugzilla.ximian.com bugzilla-daemon at bugzilla.ximian.com
Wed Aug 30 04:24:08 EDT 2006

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by informatique.internet at fiducial.fr.


--- shadow/79207	2006-08-29 14:18:33.000000000 -0400
+++ shadow/79207.tmp.12697	2006-08-30 04:24:08.000000000 -0400
@@ -91,6 +91,31 @@
 I tried moving a.exe to another directory, and it still works:
 mono-service /tmp/a.exe
+------- Additional Comments From informatique.internet at fiducial.fr  2006-08-30 04:24 -------
+I've compiled your example using :
+ mcs service.cs  -r:System.ServiceProcess
+I run mono-service ./service.exe
+Nothing append (no /tmp/service.exe.lock no message in syslog)
+If i run  /usr/lib/mono/1.0/mono-service.exe ./service.exe
+i get :
+Unhandled Exception: System.IO.FileNotFoundException: mono-service,
+Version=, Culture=neutral : mono-service, Version=,
+  at (wrapper xdomain-invoke) System.AppDomain:CreateInstanceAndUnwrap
+  at (wrapper remoting-invoke-with-check)
+  at MonoServiceRunner.Main (System.String[] args) [0x00000]
+If i copy mono-service.exe to the same directory of ./service.exe it
+works well!
+Miguel have you tried with svn version?

More information about the mono-bugs mailing list