[Mono-bugs] [Bug 79156][Nor] Changed - Unable to successfully run a process on win32 with more than one argument

bugzilla-daemon at bugzilla.ximian.com bugzilla-daemon at bugzilla.ximian.com
Fri Aug 25 15:05:18 EDT 2006

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by taktaktaktaktaktaktaktaktaktak at gmail.com.


--- shadow/79156	2006-08-25 14:27:09.000000000 -0400
+++ shadow/79156.tmp.25391	2006-08-25 15:05:18.000000000 -0400
@@ -75,6 +75,28 @@
 I guess that pkg-config doesn't get the same environment
 when called from your application. Maybe you need to set
 PKG_CONFIG_PATH or whatever, but this is not Mono's problem ;-)
+------- Additional Comments From taktaktaktaktaktaktaktaktaktak at gmail.com  2006-08-25 15:05 -------
+My environment is set up correctly.  After further testing, the sample
+app functions as expected if I run it from a "dos" prompt:
+C:\Documents and Settings\lbard>pkg-config --variable=libdir gtk-sharp-2.0
+C:\Documents and Settings\lbard>Processdemo.exe
+C:\Documents and Settings\lbard>mono Processdemo.exe
+But if I run it from an rxvt:
+/cygdrive/c/Documents and Settings/lbard> pkg-config --variable=libdir
+/cygdrive/c/Documents and Settings/lbard> ./Processdemo.exe
+/cygdrive/c/Documents and Settings/lbard> mono Processdemo.exe
+(no output)

More information about the mono-bugs mailing list