[Mono-bugs] [Bug 79096][Nor] New - Throws System.InvalidOperationException in simple GUI app

bugzilla-daemon at bugzilla.ximian.com bugzilla-daemon at bugzilla.ximian.com
Thu Aug 17 17:21:29 EDT 2006

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by troels at arvin.dk.


--- shadow/79096	2006-08-17 17:21:29.000000000 -0400
+++ shadow/79096.tmp.3725	2006-08-17 17:21:29.000000000 -0400
@@ -0,0 +1,48 @@
+Bug#: 79096
+Product: Mono: Class Libraries
+Version: 1.1
+OS Details: Fedora Core 5 x86_64 (not using Fedora Core 5's Mono)
+Status: NEW   
+Priority: Normal
+Component: Windows.Forms
+AssignedTo: peter at novonyx.com                            
+ReportedBy: troels at arvin.dk               
+QAContact: mono-bugs at ximian.com
+TargetMilestone: ---
+Summary: Throws System.InvalidOperationException in simple GUI app
+Description of Problem:
+In a small GUI app, I get Exception messages on the console from where I
+started the app:
+Unhandled Exception: System.InvalidOperationException: Cannot call Invoke
+or InvokeAsync on a control until the window handle is created
+Steps to reproduce the problem:
+1. Run the app which I've put on
+2. Click "Select input file". Hit Cancel in File Open dialog.
+3. Repeat step 2 one or a few times.
+Actual Results:
+App keeps running, but exceptions are thrown in the console.
+Expected Results:
+App keeps running, without exceptions being thrown.
+How often does this happen? 
+Every time.
+Additional Information:
+Tried the same app on a Windows host (both .Net 1.1 and 2.0) without
+getting exceptions.
+Note: I'm new to Mono and Windows.Forms. So it may be me who has simply
+overseen/mis-understood something.
+(With Mono, the program crashed, when I tried the same app.)

More information about the mono-bugs mailing list