[Mono-bugs] [Bug 78154][Maj] Changed - Assertion failed file handles.c: line 887

bugzilla-daemon at bugzilla.ximian.com bugzilla-daemon at bugzilla.ximian.com
Mon Apr 24 12:36:06 EDT 2006

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by dick at ximian.com.


--- shadow/78154	2006-04-21 15:16:14.000000000 -0400
+++ shadow/78154.tmp.6617	2006-04-24 12:36:06.000000000 -0400
@@ -62,6 +62,20 @@
 I'm probably being thick here, but what has ulimit got to do with 
 whether I get a core dump or not?
 ------- Additional Comments From gonzalo at ximian.com  2006-04-21 15:16 -------
 if 'ulimit -c' is 0, then no core dump os generated, which is probably
 the setting that you have.
+------- Additional Comments From dick at ximian.com  2006-04-24 12:36 -------
+I always specifically pass -g to CFLAGS when I run configure (ie
+"CFLAGS=-g ./configure --prefix=/blah/blah").  I don't know if the
+package binaries have debug symbols.
+Looking at, it's asserting when trying to delete a mutex. 
+I'm guessing that thr_ret == EBUSY, which means someone has tried to
+lock it.  That suggests a race condition where the handle reference
+has dropped to 0 (so we're deleting the handle and it's mutex) but
+another thread has just tried to use it. is a bit old, and
+lots has changed in the code since then. If you can reproduce this
+problem with 1.1.13.latest I will try and narrow it down.

More information about the mono-bugs mailing list