[Mono-bugs] [Bug 78035][Maj] Changed - make check fails due to errors in delegate1 and delegate2 tests

bugzilla-daemon at bugzilla.ximian.com bugzilla-daemon at bugzilla.ximian.com
Wed Apr 12 15:33:53 EDT 2006

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by matt at use.net.


--- shadow/78035	2006-04-12 12:48:27.000000000 -0400
+++ shadow/78035.tmp.27681	2006-04-12 15:33:53.000000000 -0400
@@ -197,6 +197,30 @@
 will depend highly on the memory layout as determined by gcc version,
 optimization level, kernel version, glibc version, etc, etc.
 ------- Additional Comments From vargaz at gmail.com  2006-04-12 12:48 -------
 Should be fixed in HEAD and the 1.1.13 branch. Could you recheck ?
+------- Additional Comments From matt at use.net  2006-04-12 15:33 -------
+Those valgrind warnings are now gone, thanks! The tests still fail
+during 'make check', though. When running them individually they pass.
+After a conversation with Zoltan on IRC, I tried the following
+MONO_PATH=../../../mcs/class/lib/default/ ~/bin/valgrind
+--smc-check=all --suppressions=/home/matt/src/mono/mono/data/mono.supp
+--error-limit=no --freelist-vol=50000000 mono -O=all  ./delegate1.exe
+Which produced this new valgrind warning:
+completed4: True
+==30111== Invalid read of size 8
+==30111==    at 0x455157: mono_runtime_exec_main (object.c:2097)
+==30111==    by 0x455364: mono_runtime_run_main (object.c:1962)
+==30111==    by 0x41954C: mono_main (driver.c:545)
+==30111==    by 0x5518CFF: (below main) (in /lib/libc-2.3.5.so)
+==30111==  Address 0x7FEFFFAA0 is just below the stack ptr.  
+If I run without valgrind and those commandline parameters, the test
+fails. So, this appears to be a JIT optimizer issue on amd64?

More information about the mono-bugs mailing list