[Mono-bugs] [Bug 76789][Wis] Changed - Invalid port URI format exception during remoting call

bugzilla-daemon at bugzilla.ximian.com bugzilla-daemon at bugzilla.ximian.com
Wed Nov 23 12:32:12 EST 2005

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by carlos at applianz.com.


--- shadow/76789	2005-11-23 10:01:07.000000000 -0500
+++ shadow/76789.tmp.22206	2005-11-23 12:32:11.000000000 -0500
@@ -1,13 +1,13 @@
 Bug#: 76789
 Product: Mono: Class Libraries
 Version: 1.1
 OS: other
 OS Details: Gentoo 64bit
-Status: NEW   
+Status: RESOLVED   
+Resolution: FIXED
 Severity: Unknown
 Priority: Wishlist
 Component: System
 AssignedTo: mono-bugs at ximian.com                            
 ReportedBy: carlos at applianz.com               
 QAContact: mono-bugs at ximian.com
@@ -97,6 +97,18 @@
    The remote server returned an error: (400) Bad Request.
 Can you, please, provide a test which will help to reproduce the 
+------- Additional Comments From carlos at applianz.com  2005-11-23 12:32 -------
+hmm I noticed my code had no port on the xml, so I added port="0" and
+I think it works now. Whats wierd is that it still worked on ms.net
+and mono, this is my new config.
+ <system.runtime.remoting>
+      <application>
+         <channels>
+            <channel ref="http" port="0"/>
+         </channels>
+      </application>
+   </system.runtime.remoting>

More information about the mono-bugs mailing list