[Mono-bugs] [Bug 76789][Wis] New - Invalid port URI format exception during remoting call

bugzilla-daemon at bugzilla.ximian.com bugzilla-daemon at bugzilla.ximian.com
Tue Nov 22 16:05:34 EST 2005

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by carlos at applianz.com.


--- shadow/76789	2005-11-22 16:05:34.000000000 -0500
+++ shadow/76789.tmp.9117	2005-11-22 16:05:34.000000000 -0500
@@ -0,0 +1,59 @@
+Bug#: 76789
+Product: Mono: Class Libraries
+Version: 1.1
+OS: other
+OS Details: Gentoo 64bit
+Status: NEW   
+Priority: Wishlist
+Component: System
+AssignedTo: mono-bugs at ximian.com                            
+ReportedBy: carlos at applianz.com               
+QAContact: mono-bugs at ximian.com
+TargetMilestone: ---
+Summary: Invalid port URI format exception during remoting call
+I upgraded my mono runtime to 1.1.10 and now the remoting code that was
+working just fine is giving me the following exception:
+Unhandled Exception: System.UriFormatException: Invalid URI: Invalid port
+in <0x00ca9> System.Uri:Parse (System.String uriString)
+in <0x0001b> System.Uri:ParseUri ()
+in <0x00010> System.Uri:Parse ()
+in <0x00098> System.Uri:.ctor (System.String uriString, Boolean dontEscape)
+in <0x0001d> System.Uri:.ctor (System.String uriString)
+in (wrapper remoting-invoke-with-check) System.Uri:.ctor (string)
+in <0x00030> System.Net.ServicePointManager:FindServicePoint (System.String
+uriString, IWebProxy proxy)
+in <0x00032>
+(System.String channelURI)
+in <0x002f1>
+(System.String url, System.Object remoteChannelData, System.String objectURI)
+My code wasn't changed at all, I literally just installed the new mono
+release and reran the code. I rolled back to mono and my code
+worked fine again.
+I then got the latest code from SVN (on monday nov 21st) and ran my code
+again, now the exception moved from the remoting Server to the remoting
+I edited the code to see the output of the invalid port and what I got was:
+ which does look invalid but I don't know how that got
+there or why it works fine on
+A little about my code, I have a remoting server on a console app, it
+publishes an instance of an object that is marshal by ref, then a webpage
+running on xsp gets that instance and calls a few methods on it. All method
+calls work just fine other than one method call in which one of the
+parameteres passed on the method is also a marsha by ref object. But like I
+said this code worked on
+I will try to write up and example to reproduce it but can't make any promises.

More information about the mono-bugs mailing list