[Mono-bugs] 2005-03-09 / mono-1.1.4 on solaris8 using gcc-3.2

Jochen Hayek Jochen@Hayek.name
Wed, 09 Mar 2005 02:50:24 +0100


recently I got mono compiled+linked+running with the configuration
described above.

I would like to share my experiences,
mainly so that my next mono installation on that platform
will be a little smoother ;-)

I started with this:

    ./configure --prefix=$PREFIX --with-libiconv=gnu --with-icu=yes

At one stage the build process ("make") tried to use an "mcs",
assumed to be already installed from a previous installation.
But there wasn't a previous installation,
but instead there was a pretty different "mcs" within /usr/ccs/bin.
To avoid getting that one used,
my next executions of "make" got an "env PATH=....." "prepended",
where /usr/ccs/bin got excluded from my PATH for the time being.
Maybe now, that the developers of mono know of this little problem,
they are kind enough to find a way around.

A little later the build process failed in the context of "jay".

I had to a the following line in mcs/build/config.make :

    CC = gcc

as otherwise make insisted in exactly that context on using "cc" instead,
which is a bad idea on our machine.
For later use during "make install" I had to add in the same file this entry:

    INSTALL= $(prefix)/bin/install

as otherwise make would insist on using /usr/bin/install instead,
which we don't have either.

Once I got "make" completed, I tried a "make check".
Well, the 28 or so regression test errors frustrated me a little,
but I decided not to worry about them for the time being.

With the line mentioned above, "make install" did an almost proper job.
"Almost" because apparently it wasn't really perfect,
as mcs and mono decided to start up properly only,
if they find my MONO_PATH env. variable with this value:


Honestly! If I unset that env. variable, I get an error message like this
(and after that, everything would stop):

    GLib: Cannot convert message: Conversion ... not supported

Obviously I managed this time to overcome all these obstacles,
and presumably my upgrade in a couple of weeks will cost me a couple of
hours less, but still ...

Feedback appreciated.
I am quite willing to try a couple of patches and retry the build process

I do not have subversion installed here,
and as we live behind a firewall here,
"svn+ssh" is not the option to go.
(Yes, I know, there are ways to PRELOAD "something" in order to ssh
through the proxy's https port, but still ...)
But I will manage to use Larry Wall's "patch" utility,
in case somebody provides me with a patch.

In case this is not quite the right mailing list for this topic,
pls give me a notice, where to head for and where to post this again!

Kind regards,