[Mono-bugs] [Bug 75617][Maj] New - Can't mix generics and non-generics

bugzilla-daemon at bugzilla.ximian.com bugzilla-daemon at bugzilla.ximian.com
Sun Jul 24 06:36:30 EDT 2005

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by c_feller at informatik.uni-kl.de.


--- shadow/75617	2005-07-24 06:36:30.000000000 -0400
+++ shadow/75617.tmp.14926	2005-07-24 06:36:30.000000000 -0400
@@ -0,0 +1,48 @@
+Bug#: 75617
+Product: Mono: Runtime
+Version: 1.1
+OS: All
+OS Details: 
+Status: NEW   
+Severity: Unknown
+Priority: Major
+Component: misc
+AssignedTo: mono-bugs at ximian.com                            
+ReportedBy: c_feller at informatik.uni-kl.de               
+QAContact: mono-bugs at ximian.com
+TargetMilestone: ---
+Summary: Can't mix generics and non-generics
+Please fill in this template when reporting a bug, unless you know what you
+are doing.
+Description of Problem:
+When I load an assembly (compiled with gmcs) into an application (compiled
+with mcs) i get a warning: Could not load class from
+Systen.Collections.Generic.List'1 and a NullReferenceException.
+If I compile the application with gmcs the exception does not occur.
+Steps to reproduce the problem:
+1. Download the attachment.
+2. Unzip/tar it.
+3. run "make" and "mono LocalLoad.exe" 
+4. See an exception
+5. run "make generic" and "mono LocalLoad.exe"
+6. See "This is a test!" printed.
+Actual Results:
+exception/"This is a test!" depending on how you compiled the main assembly.
+Expected Results:
+"This is a test!" in both cases.
+How often does this happen? 
+As often as I tried.
+Additional Information:
+Tried with 1.1.6 and 1.1.8 under Windows and Linux.

More information about the mono-bugs mailing list