[Mono-bugs] [Bug 55996][Nor] Changed - Appdomain unloading problems under Nunit/NAnt

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Mon, 7 Feb 2005 18:37:37 -0500 (EST)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by cmars@ziplip.com.


--- shadow/55996	2004-11-18 09:59:15.000000000 -0500
+++ shadow/55996.tmp.28152	2005-02-07 18:37:37.000000000 -0500
@@ -1,13 +1,13 @@
 Bug#: 55996
 Product: Mono: Runtime
 Version: unspecified
 OS: unknown
 OS Details: 
-Status: RESOLVED   
-Resolution: FIXED
+Status: REOPENED   
 Severity: Unknown
 Priority: Normal
 Component: misc
 AssignedTo: vargaz@gmail.com                            
 ReportedBy: vargaz@freemail.hu               
 QAContact: mono-bugs@ximian.com
@@ -43,6 +43,40 @@
 gzipped verbose log showing issue
 ------- Additional Comments From vargaz@gmail.com  2004-11-18 09:59 -------
 There were fixes in 1.1.2 and 1.0.4 for finalizers&unloading, so I hope
 this works now. If there are still problems, feel free to reopen it.
+------- Additional Comments From cmars@ziplip.com  2005-02-07 18:37 -------
+I am getting some strange behavior with NAnt-0.85rc1 and Mono-1.0.5. 
+I built mono-1.0.5 and its companion packages from sources on Ubuntu
+When I run NAnt, it starts up and runs but crashes intermittently
+during the execution of a build.  The crash happens at different
+points in the build when run repeatedly.  If you only had one target,
+you might miss it, but a large script, such NAnt's own buildfile, it
+crashes every time.
+I tried commenting out all the AppDomain.Unload calls from the NAnt
+sources but the bootstrap NAnt.exe (the shipped NAnt binary that is
+supposed to compile NAnt) crashes before I can get a complete build.
+I have tried setting MONO_NO_UNLOAD=1 to no avail.
+The build crashes three possible ways:
+1. "Unhandled Exception: System.NullReferenceException" and mono hangs.
+2. "Segmentation fault" and mono dies.
+3. Mono mysteriously hangs w/no message.  Process has to be killed.
+Sometimes, I get free(): invalid pointer (0xsome address) messages as
+What should I send to help you debug this problem?  It is
+nondeterministic, so I am not sure what would help.
+Thank you,