[Mono-bugs] [Bug 77123][Nor] Changed - file object.c: line 503 (compute_class_bitmap): assertion failed: ((field->offset % sizeof(gpointer)) == 0)

bugzilla-daemon at bugzilla.ximian.com bugzilla-daemon at bugzilla.ximian.com
Thu Dec 29 15:16:57 EST 2005

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by vargaz at gmail.com.


--- shadow/77123	2005-12-29 15:05:54.000000000 -0500
+++ shadow/77123.tmp.22608	2005-12-29 15:16:57.000000000 -0500
@@ -1,14 +1,14 @@
 Bug#: 77123
 Product: Mono: Runtime
 Version: unspecified
 OS: GNU/Linux [Other]
 OS Details: ubuntu breezy
-Status: NEW   
+Status: RESOLVED   
+Resolution: DUPLICATE
+Severity: Unknown
 Priority: Normal
 Component: misc
 AssignedTo: mono-bugs at ximian.com                            
 ReportedBy: tjfontaine at gmail.com               
 QAContact: mono-bugs at ximian.com
 TargetMilestone: ---
@@ -194,6 +194,11 @@
 Additional Information:
 The code compiles fine and runs as expected on ms.net 2.0. I tried several
 different ways to get around it, as it's own seperate assembly, generics
 and no unsafe, no generics with unsafe, and no generics and no unsafe,
 compiling with gmcs or mcs, with latest svn or 1.1.10 on multiple linux
 systems. All resulted in the same error.
+------- Additional Comments From vargaz at gmail.com  2005-12-29 15:16 -------
+Try removing the Pack=1 from the structures.
+*** This bug has been marked as a duplicate of 76717 ***

More information about the mono-bugs mailing list