[Mono-bugs] [Bug 62395][Nor] Changed - Kill() won't kill

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Thu, 28 Apr 2005 19:56:15 -0400 (EDT)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by michi@zeroc.com.


--- shadow/62395	2004-08-04 18:12:29.000000000 -0400
+++ shadow/62395.tmp.3618	2005-04-28 19:56:15.000000000 -0400
@@ -64,6 +64,22 @@
 ------- Additional Comments From dick@ximian.com  2004-08-04 18:12 -------
 How about System.Environment.Exit()?
+------- Additional Comments From michi@zeroc.com  2005-04-28 19:56 -------
+I also used the sleep trick. That worked fine, until I ran on an RH8 
+machine in single-CPU mode. It looked like the calling thread was 
+simply sleeping, and then, once the (2 second) sleep completed, Exit
+() went on its merry way as usual.
+I've changed the code to fork a new process that does 
+a "/usr/bin/kill -s 9 <mypid>". This works, but isn't very elegant. 
+I'd like to use platform invoke instead to call the kill() system 
+call directly. Is this possible? Which library do I need for the 
+DllImport directive?
+One other question: in general, when I want to use platform invoke, 
+it's not always obvious in which library I can find the entry point. 
+Is there any way to find out?