[Mono-bugs] [Bug 66131][Nor] New - Mono cannot open assemblies until you run Mint

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Thu, 16 Sep 2004 19:54:33 -0400 (EDT)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by vance@vancesoft.com.


--- shadow/66131	2004-09-16 19:54:33.000000000 -0400
+++ shadow/66131.tmp.16692	2004-09-16 19:54:33.000000000 -0400
@@ -0,0 +1,45 @@
+Bug#: 66131
+Product: Mono: Runtime
+Version: unspecified
+OS Details: Solaris 9
+Status: NEW   
+Priority: Normal
+Component: misc
+AssignedTo: mono-bugs@ximian.com                            
+ReportedBy: vance@vancesoft.com               
+QAContact: mono-bugs@ximian.com
+TargetMilestone: ---
+Summary: Mono cannot open assemblies until you run Mint
+Description of Problem:
+Steps to reproduce the problem:
+1. Compile and install Mono 1.0.1 runtime
+2. Use mcs to compile hello.cs and create hello.exe
+3. Run mono hello.exe
+Actual Results:
+I get the following error:
+cannot open assembly help.exe
+Expected Results:
+Hello world!
+How often does this happen? 
+Just after the initial install.
+Additional Information:
+I tried it several times, and got the same error every time.  I tried
+recompiling and running mono and got the same error.  I then ran a hex
+viewer to see if the file looked correct.  It did, containing the correct
+source code.  Then I ran it with mint instead of mono and it ran correctly.
+ After that, mono worked every time.  I tried creating another program and
+compiling and mono worked on it without running mint.  My theory is that
+mint is automatically setting some configuration information that mono