[Mono-bugs] [Bug 65458][Maj] Changed - build (configure) in libgc is broken on Windows

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Tue, 5 Oct 2004 17:01:48 -0400 (EDT)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by atsushi@ximian.com.


--- shadow/65458	2004-10-05 14:38:14.000000000 -0400
+++ shadow/65458.tmp.25832	2004-10-05 17:01:48.000000000 -0400
@@ -109,6 +109,24 @@
 ------- Additional Comments From vargaz@gmail.com  2004-10-05 14:38 -------
 Atsushi, could you check whenever updating cygwin fixes your problem
 too ?
+------- Additional Comments From atsushi@ximian.com  2004-10-05 17:01 -------
+Not fixed. In fact
+- Yes, I once experienced that monoburg hang. It was when I tried to
+use another set of dependencies (glib/icu/libgc etc.), but not sure
+what caused it. I cannot reproduce it now :(
+- The "libgc=boehm" problem seems still there (maybe in some
+conditions it would disappear, but not sure why)
+- With the latest mingw runtime, it resulted in the error:
+/usr/i686-pc-mingw32/include/unistd.h:23: error: conflicting types for
+/opt/gnome2.4.1/include/glib-2.0/glib/gwin32.h:72: error: previous
+declaration of `g_win32_ftruncate'
+I tried the latest glib (2.4.5) from tml
+(http://www.gimp.org/~tml/gimp/win32/), but no difference.