[Mono-bugs] [Bug 69582][Wis] New - Wrong dates returned through SQL query

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Tue, 16 Nov 2004 19:27:18 -0500 (EST)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by scott.grosch@intel.com.


--- shadow/69582	2004-11-16 19:27:18.000000000 -0500
+++ shadow/69582.tmp.3587	2004-11-16 19:27:18.000000000 -0500
@@ -0,0 +1,50 @@
+Bug#: 69582
+Product: Mono: Runtime
+Version: unspecified
+OS: RHEL 2.1
+OS Details: 2.4.9-45lxset12smp 
+Status: NEW   
+Severity: Unknown
+Priority: Wishlist
+Component: misc
+AssignedTo: mono-bugs@ximian.com                            
+ReportedBy: Scott.Grosch@intel.com               
+QAContact: mono-bugs@ximian.com
+TargetMilestone: ---
+Summary: Wrong dates returned through SQL query
+Please fill in this template when reporting a bug, unless you know what 
+you are doing.
+Description of Problem:
+Using a call into the SQL server that returns a SmallDateTime object, I'm 
+getting incorrect results.  I've run the stored procedure via Microsoft's 
+SQL Query Analyzer and on UNIX via the FreeTDS libraries, both of which 
+return the date I expect.
+When I run my app on windows directly I also get the expected dates.  
+When I run via mono on my Linux box, I'm getting dates in the year 1825 
+instead of 2004 and 2005
+Steps to reproduce the problem:
+1. Create a connect, create a command object, call stored procedure
+2. Use a SqlDataReader and call reader.GetDateTime(1)
+3. Print the date
+Actual Results:
+Expected Results:
+How often does this happen? 
+Every time I make this call
+Additional Information: