[Mono-bugs] [Bug 69346][Nor] New - mcs.exe aborts on amd64 when using JIT

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Wed, 10 Nov 2004 19:22:24 -0500 (EST)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by junk@giantblob.com.


--- shadow/69346	2004-11-10 19:22:24.000000000 -0500
+++ shadow/69346.tmp.15439	2004-11-10 19:22:24.000000000 -0500
@@ -0,0 +1,39 @@
+Bug#: 69346
+Product: Mono: Compilers
+Version: 1.1
+OS Details: 
+Status: NEW   
+Priority: Normal
+Component: C#
+AssignedTo: mono-bugs@ximian.com                            
+ReportedBy: junk@giantblob.com               
+QAContact: mono-bugs@ximian.com
+TargetMilestone: ---
+Summary: mcs.exe aborts on amd64 when using JIT
+mcs.exe aborts during bootstrap on amd64 when using JIT on recent Gentoo.
+  Gentoo 2004.2
+  gcc-3.4.3
+  glibc-2.3.4
+Tried to bootstrap both mono-1.1.2 and also mono from cvs 10 November. I
+compiled mono-1.1.2 then tried to use it with monolite to bootstrap mcs. 
+Fails to build mcs.exe with message:
+Compilation succeeded
+I've succesfully bootstrapped mcs on 32 bit, so I think I'm doing it correctly.
+Not sure exactly what further information you would need to reproduce this
+but I'd like to help.
+-- jeek