[Mono-bugs] [Bug 69258][Wis] Changed - mod_mono fails to start. undefined symbol: apr_socket_send

bugzilla-daemon@bugzilla.ximian.com bugzilla-daemon@bugzilla.ximian.com
Wed, 10 Nov 2004 13:34:33 -0500 (EST)

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.

Changed by jackchen@tcn.net.


--- shadow/69258	2004-11-09 21:51:36.000000000 -0500
+++ shadow/69258.tmp.11656	2004-11-10 13:34:33.000000000 -0500
@@ -35,6 +35,30 @@
 This should probably be set as an RPM dependancy and also set as a 
 dependancy in autoconfig.  I tried the RPMs and the sources and 
 nothing every complained to me.
 ------- Additional Comments From gonzalo@ximian.com  2004-11-09 21:51 -------
 --> packaging
+------- Additional Comments From jackchen@tcn.net  2004-11-10 13:34 -------
+I met the exactly same error on Apache 2.0.40 and Redhat 9.0. Tried 
+to install apr-1.0.0 and apr-util-1.0.0 with source code, didn't fix 
+the problem. installed apr-util-0.9.4-14.i386.rpm and apr-0.9.4-
+11.i386.rpm , didn't fix the problem. I found the installation just 
+put  libapr-0.so.0.9.4 to /usr/lib, the libapr.so.0 still use the old 
+libapr.so.0.0.0 . The httpd always use libapr.so.0 . I tried manually 
+link libapr.so.0 and libaprutil.so.0 to 0.9.4 version so, but it give 
+me the following error:
+Starting httpd: /usr/sbin/httpd: relocation 
+error: /usr/lib/libapr.so.0: symbol sys_siglist, version GLIBC_2.3.3 
+not defined in file libc.so.6 with link time reference
+If I use the apr-1.0.0 version so, I got the following error:
+Starting httpd: /usr/sbin/httpd: relocation error: /usr/sbin/httpd: 
+undefined symbol: apr_filename_of_pathname
+Can somebody give me a hint? I am so frustrated :-(